SamochodyElektryczne.org - Forum
SamochodyElektryczne.org

Układy energoelektroniczne - sterowanie dwoma silnikami

Arni - 2015-12-06, 11:22
Temat postu: sterowanie dwoma silnikami
Stanąłęm przed następujacym problemem: jak rozwiązac sterowanie 2 silników jednocześnie. Silniki pochodzą ze skuterów elektrycznych, jeszcze ich nie mam więc nie mogę powiedzieć nic bliższego niz to, że są na 48V, mają 2 kW i będą w komplecie z oryginalnymi sterownikami i manetkami. Jak sie domyślam są to silniki BLDC
Czy zastosować oryginalne sterowniki tylko podpiąć je do jednej manetki czy tez może jest jakiś sterownik dedykowany do zdublowanych napędów? Czy też nalezy traktować każdy układ zupełnie osobno i dać dwie manetki sprzężone tylko mechanicznie? Domyślam się, że będzie jeszcze problem kalibracji tak, żeby oba silniki były obciążone równomiernie.
No i ostatnie pytanie :) Czy da się w takim układzie sterowania zrobić bieg wsteczny? czy tylko rozwiazanie mechaniczne wchodzi w grę?
Mam dzis dostać trochę więcej szczegółów ale wszystko bedę wiedział, kiedy klamoty przyjadą do mnie

zeeltom - 2015-12-06, 12:47

Jedna wspólna manetka, dwa sterowniki i dwa silniki. Wszystko musi być tej samej firmy i ten sam model.
Nie ma kontrolerów pojedynczych dla dwóch silników BLDC.

Arni - 2015-12-06, 14:29

zeeltom napisał/a:
Jedna wspólna manetka, dwa sterowniki i dwa silniki. Wszystko musi być tej samej firmy i ten sam model.
Nie ma kontrolerów pojedynczych dla dwóch silników BLDC.


Tak myślałem :) Nie bedzie problemu bo to mają byc dwa identyczne komplety.

A co ze wstecznym biegiem?

zeeltom - 2015-12-06, 15:14

Jeśli sterownik nie ma takiej funkcji, to musisz zamienić miejscami po dwa hallotrony i dwie fazy w każdym silniku. Można to zrobić na przekaźnikach (stycznikach) lub wielosegmentowym przełączniku.
Arni - 2015-12-06, 15:48

zeeltom napisał/a:
Jeśli sterownik nie ma takiej funkcji, to musisz zamienić miejscami po dwa hallotrony i dwie fazy w każdym silniku. Można to zrobić na przekaźnikach (stycznikach) lub wielosegmentowym przełączniku.


Super, to dam rade ogarnąć sam. Dzięki za odpowiedzi, mam nadzieje że mój projekt w końcu nabierze tempa.

gienek333 - 2015-12-06, 22:51

Wszystko zależy co te silniki mają napędzać. Jeżeli w jednośladzie, to jeden może być elektryczny, a drugi nawet parowy (momenty się dodają).
zeeltom - 2015-12-07, 09:19

Ciekawe tylko po co wsteczny w jednośladzie? ;)
Arni - 2015-12-07, 16:12

zeeltom napisał/a:
Ciekawe tylko po co wsteczny w jednośladzie? ;)


bo to nie jest jednoślad :)
Jeśli koncepcja się uda to będzie nawet 4-ślad ;)

zinho - 2015-12-07, 19:03

To jakis dyferencjal bedzie potrzebny raczej
zeeltom - 2015-12-07, 19:14

Nie będzie potrzebny, bo będzie dyferencjał elektroniczny w postaci dwóch silników i kontrolerów.
Arni - 2015-12-07, 19:58

zeeltom napisał/a:
Nie będzie potrzebny, bo będzie dyferencjał elektroniczny w postaci dwóch silników i kontrolerów.


To też musiałem rozważyć ale raz ze własnie dwa równe silniki to bedą napedzać a dwa, że rozstaw tych dwóch kółek będzie niewielki wiec róznica w obrotach tez niewielka

zeeltom - 2015-12-08, 05:55

Już się domyślam, co to będzie ;)
Arni - 2015-12-21, 18:22

zeeltom napisał/a:
Już się domyślam, co to będzie ;)


Pewnie dobrze sie domyślasz :) Niedługo bedzie więcej szczegółów ale na razie są kolejne pytania:

na silniku osadzonym w feldze 10" jest tylko jeden napis 48V - J L2007 04120 z czego ostatnia sekcja sie zmienia (numer fabryczny?)
jak okreslić jakiej mocy jest ten silnik?

sterownik ma napisy po chinsku, postaram się póżniej wrzucic fotke ale są na nim między krzaczkami takie czytelne oznaczenia:
KZQC-48 60 *(stopni)
48 V 12 A
42,5 +/- 0,5V 25 +/- 0,5A

Podobno jest to zestaw. Ile on moze mieć realnie mocy?

zeeltom - 2015-12-21, 21:09

Kontroler daje 500W, to i pewnikiem silnik tyle ma, skoro to komplet.
Arni - 2016-05-28, 23:46

Witajcie ponownie :)
Pół roku minęło, za długa historia żeby opisywać boje ze sprzedawcą ale koniec końców mam silniki ze sterownikami. Silniki takie same, sterowniki - prawie. I tu właśnie mam problem. Sterowniki są produkcji firmy SHIWEI Electron, model SWK152048 czyli 1500-2000W 48V Na obu jest identyczna naklejka z rozpiską kabli, taka jak na 1 zdjęciu tu:
Zdjęcia
ale jeden z nich ma dodatkowe kable widoczne na drugim zdjęciu. Nie przejmowałbym się nimi ale akurat ten sterownik nie działa. W momencie dodania gazu słychać tylko ciche stukniecie w silniku ale się nie kręci. Robiłem próby krzyżowe i na tym pierwszym sterowniku oba silniki chodzą a na tym drugim żaden z nich wiec to problem ze sterownikiem. Pozostaje tylko pytanie czy sterownik jest uwalony czy tez na którymś z tych kabli jest dodatkowa blokada? Ściągnąłem mnóstwo dokumentacji do pojazdów gdzie podobne napędy są używane ale przeznaczenie tych kabelków jest dla mnie nadal zagadką. Z racji ciężkiego kontaktu ze sprzedającym chwilowo odpuściłem najprostsze rozwiązanie czyli wymianę na inny egzemplarz sterownika. Dodatkowe funkcjonalności tego sterownika być może by mi się przydały

zeeltom - 2016-05-29, 05:34

Rozkręć oba i porównaj płytki z wychodzącymi przewodami.
Może w tym działającym sterowniku te kabelki są pozwierane na płytce i ich nie podłączono. Coś mnie kusi, że może to stacyjka, lub coś podobnego, może hamulce?

Arni - 2016-05-29, 10:44

zeeltom napisał/a:
Rozkręć oba i porównaj płytki z wychodzącymi przewodami.
Może w tym działającym sterowniku te kabelki są pozwierane na płytce i ich nie podłączono. Coś mnie kusi, że może to stacyjka, lub coś podobnego, może hamulce?


Wstępnie odkręciłem pokrywy ale ta chińszczyzna jest pozalewana plastikiem i wymaga to sporej destrukcji, żeby sie dostać pod płytkę. Jakość montażu wskazuje na sporą amatorkę ;) Nie chciałem na razie grzebać o ile miałbym zwracać ten sterownik. Może jednak w imię posiadania dodatkowych funkcji zaryzykuję reverse engineering ;)
Na naklejce jest opisany "thin purple" jako "brake" i ten kabel zidentyfikowałem, jest w obu sterownikach. Ten z obciętą końcówką jest trochę bardziej "purple" od tamtego. Chciałbym, żeby to był rewers ale wątpię, być może to sygnał na prędkościomierz? Chodzi po głowie, ze niebieski z pomarańczowym może być blokadą antykradzieżową ale tam występuje 48V i nie chce tego tak na żywca zwierać.

zinho - 2016-05-30, 08:45

Probowaleś zmieniac sekwencje przewodow? Masz tam przewod power lock musi on byc dolaczony do + sterownika. Jak nie to sprawdz czy tranzystory i bezpieczniki sa sprawne. Sprobuj jeszcze podlaczyc ten niedzialajacy sterownik do tego silnika z ktorym dziala dzialajacy sterownik moze w silniku masz hallotrony uszkodzone
Arni - 2016-05-30, 10:29

zinho napisał/a:
Probowaleś zmieniać sekwencje przewodów? Masz tam przewód power lock musi on byc dolaczony do + sterownika. Jak nie to sprawdz czy tranzystory i bezpieczniki sa sprawne. Sprobuj jeszcze podlaczyc ten niedzialajacy sterownik do tego silnika z którym dziala dzialajacy sterownik może w silniku masz hallotrony uszkodzone


tak jak pisałem wcześniej próba krzyżowa zrobiona i nie działa tylko ten jeden sterownik. Wszystkie kable opisane na naklejce były podłączone. bez power locka oczywiscie nie chce ruszyć. W momencie ruszenia manetką gazu w obu silnikach na obu sterownikach słychać takie ciche stuknięcie i na dobrym sterowniku zaczyna się kręcić a na tym z problemami nie. Będę musiał zrobić próbę na otwartym sterowniku z pomiarami, może wyjdzie jakaś nieprawidłowość no i obejrzę płytkę czy faktycznie w tym dobrym nie ma jakichś zwor w miejscu tajemniczych kabli.

Jeszcze taka obserwacja poza konkursem: podanie zasilania do układu sterownika generuje niezły pobór prądu bo aż iskry na klemach skakały, na początku myślałem, że sterownik ma zwarcie albo coś zle podłączyłem. Ale okazało się, że po drugim i następnym dotknięciu już nie strzela a układ działa. Sytuacja się powtarza po odpięciu akumulatora i ponownym podłączaniu. Po zasileniu przewodu power lock przekaźnik w sterowniku załącza co trzeba. Na obu sterownikach jest tak samo tylko ten jeden nie chce silnikiem kręcić. A oscyloskopu nie mam, może czas się rozejrzeć za jakimś?

EVgarage - 2016-05-30, 14:09

Duży prąd przy włączaniu do akumulatora wynika z ładowania kondensatorów. A co do oscyloskopu to za okolice 100pln są takie cyfroweukłady z wyświetlaczem działające jako oscyloskop. Nie jest to idealnie dokładne ale spełnia swoją funkcję ;)
zinho - 2016-05-30, 19:57

Mi to mi wygląda na albo uszkodzenie któregoś z hallotronów, może coś nie łączyć. Spróbuj przy innych sekwencjach obrócić ręcznie wirnik i dopiero później użyć manetki.


Takie stukniecie charakterystyczne jest z mojego doświadczenie na problem z hallotronami może coś nie stykać itp. Sprawdź też czy na wyjściu sterownika jest napięcie zasilające do hallotronów, można też dosyć łatwo sprawdzić czy masz hallotrony są sprawne.

Arni - 2016-05-30, 20:04

ale hallotrony są w silniku a oba silniki - jak juz napisałem - na drugim sterowniku chodzą poprawnie. I też stukają. A właściwie cykają przed rozruchem. Na tym zagadkowym nie działa żaden, pomaganie, obracanie nic nie daje. Tak wiec to raczej mylny trop, trzeba rozgryźć sterownik. Staram się działać systematycznie, dzięki temu że są dwa zestawy mam możliwość robienia porównań. Tak sie zastanawiam, czy ten "wadliwy" sterownik może być na inny układ halotronów? Mimo że prosiłem sprzedającego o komplet tak jak w oryginale było to jednak powybierał z kartonu co mu pasowało, gościu w ogóle nie ogarnia takich tematów
Pir-serwis - 2016-05-30, 23:36

Halotrony są w silniku a wiązka od sterownika ok? W środku nie oberwało się?
zeeltom - 2016-05-31, 15:55

Co wy z tymi hallotronami? Przecież chłopak pisze wyraźnie, że oba silniki chodzą na jednym kontrolerze, a na drugim nie. To chyba jasne, że hallotrony w obu silnikach są sprawne.
Pir-serwis - 2016-05-31, 21:04

Zeltom czytaj ty wyraźnie.
Halotrony ok, ale wiązka sterownik silnik wadliwa !

zeeltom - 2016-06-01, 03:16

Jeszcze nie miałem takiego przypadku. Ale to dość łatwo sprawdzić woltomierzem i omomierzem. Szczególnie mając drugi, taki sam kontroler.

Powered by phpBB modified by Przemo © 2003 phpBB Group